PLEASE READ THIS BEFORE BUYING!


You need a full-version of NI Reaktor 5 or 6 to use our instruments!    In Reaktor-Player they run only for 30 minutes per each start!

Reaktor 6 is supported, but not necessary - but you need at least a FULL version of #5 (5.92 to be exactly)!

Sooner or later we maybe find a reason to update to Reaktor #6. At this point you will also need #6 to use our latest updates! 

As soon as we plan switch to Reaktor 6, we will inform you at least 3 months before!


There are still problems with Firefox: The whole shopping-process will not work, the site looks ugly.

We recommend a current Chrome or Safari.


You need a valide paypal-account!

If you do not have paypal:  Go to contact and email us, we will find another way!



Try before buy!